Back
Maintenance

School Wide Network Maintenance

Completed 31 May at 04:00pm BST.

Phones Wifi
Completed

Maintenance completed

Posted 31 May at 04:00pm BST.
Started

There is maintenance occuring to the schools network, loss of wifi and phones may occur in any building at any time.

Posted 30 May at 08:00am BST.